FOVEX 360s/Menus Toolbars and Windows

From FOVEX Help
Jump to: navigation, search


Introduction

When FOVEX 360S is first started, the main window opens up with a default layout:

When FOVEX 360S is first started, the main window opens up with a default layout


The center of the application window is reserved for the display of images, measurements and adjustment results (Image View, Network View, Report View and Layer View). Other parts are: image Thumbnails View. Job Manager, standard menu and toolbars, Properties and Message Log.


FOVEX 360S after opening a project file.

Menu Bar

Menus of FOVEX 360S


The File menu:

The File menu


File Menu Description
New Solution creates a new empty solution or project. After creation of a solution a project can be added to the project.
Open Solution opens an existing solution or project from a file
Save Solution saves the current solution to a file
Save Project saves the current active/open project to a file.
Save Solution as ... saves the current solution to a file with a user-specified file name
Save Project as ... saves the current active/open project to a file with a user-specified file name
Export exports network points and CAD objects in a file with a dxf format
Settings ... opens the application setting editor
Recent Solution shows the list of recently opened solution
Recent Project shows the list of recently opened project
Exit terminates the FOVEX 360S program


The View menu:

The View menu:


View > Dock Windows Menu Description
Project Explorer window is used to visualize and create project data items such as panoramic camera and image data. It also allows editing of property values of certain data items
Message Log window provides an area for information messages such as progress of activities, warnings or errors. Message may be filtered out on the basis of severity level and/or keyword
Thumbnail View window is used to provide a thumbnail view of images of a certain frame array or panoramic camera. Left-click on a camera in the Project Explorer updates the thumbnails in the view
Job Manager window is used to show the currently running job or the queued tasks which will be running after each other
Properties window is used to show the property of the selected CAD shape in Image View


View > Toolbars Menu Description
Drawing Toolbar shows/hides the following tools:

 Drawing Toolbar

Image Viewer Mode shows/hides the following tools:

 Image Viewer Mode

Layer tools shows/hides the following tools:

 Layer tools

Solution shows/hides the following tools:

 Solution

Adjustment shows/hides the following tools:

 Adjustment

Modifier shows/hides the following tools:

 Modifier

Auto Process shows/hides the following tools:

 Auto Process


The Draw menu:

The Draw menu


Draw Menu Description
Draw manual point Places a points on image which has been opened at Image View
Draw automatic point Place a point semi-automatically on the opened image at Image View. This item identifies round-shape target and places a point in the center of the round shape target
Draw a line between 2 points By selecting two image points, it draws a line between them
Draw a Polyline through a sequence of points Draws a polyline by selecting more than 1 image point
Draw a Circle through 3 points on the circle Draws a circle by selecting 3 points
Draw a Rect through 3 edge point Draws a rectangle by selecting 3 points. The fourth point is computer by using the 3 points


These tools are available in the toolbar of the Image View.


The Window menu:

The Window menu


Window Menu Description
Close All Images closes all opened images at image view
Split Mode arranges the opened images according to pre-defined columns of images at the following structure:
  • Window > Split Mode > 1 x n
  • Window > Split Mode > 2 x n
  • Window > Split Mode > 3 x n
  • Window > Split Mode > 4 x n
  • Window > Split Mode > 5 x n
Tile Images tiles open images


The Help menu

The Help menu


Help Menu Description
User Guide The link to user guide (this document)
Languages changes the language of FOVEX 360S
Software Activation opens the activation dialog box
Update opens FOVEX Get to update software and or add-on
About opens the About windows

Toolbar

The following describes the tool bars of FOVEX 360S software.

Main Toolbar

F360s MenusToolbarsandWindows Toolbar 1.jpg


Project Wizard …toolbar Project Wizard toolbar

  • A step by step guide to create a project and perform automated image orientation and point cloud generation.

Solution toolbar Solution toolbar

  • New solution creates a new solution
  • Open Solution opens an existing solution file
  • Save Solution save the solution in a file.

Adjustment toolbar Adjustment toolbar

  • Orient Images perform image orientation with bundle adjustment including self-calibration of the camera if the additional parameters of the camera are set free.

Modifier toolbar Modifier toolbar

  • Reset Exterior Orientation sets the images to a non-oriented mode and the value of exterior orientation parameters to 0.
  • Active All Inactive Image Points Activate all image points and performs a forward intersection of all existing image points
  • Clear All Image Point Labels clears the label of image point
  • Delete All Image Points deletes all image points

Auto Process toolbar Auto Process toolbar

  • Auto Process with Natural Features performs the following:
    • natural feature extraction
    • feature matching/labeling
    • Image orientation
    • Camera self-calibration
  • Point Cloud with Dense Matching computes a point cloud by dense matching

Image view Toolbar

Image view Toolbar


  1. Draw a Circle through 3 points on the circle
  2. Draw a Rec through 3 edge points
  3. Draw a line between 2 points
  4. Draw a Polyline through a sequence of points
  5. Draw automatic point
  6. Draw manual point
  7. Prefix of the image point label
  8. Postfix of the image point label
  9. On/off image
  10. Auto pan & drop image point
  11. Re-scale Images
  12. Image display filter Image display filter
  13. Image Arrangement: Image Arrangement
  14. Show/Hide 2D Residual Vectors
  15. Factor of magnification of the 2D residual vectors
  16. Open the layer View Widget

Network View Toolbar

Network View Toolbar


  1. Reset
  2. Fit Network to view
  3. Screenshot
  4. Point based Representation
  5. Wire frame based Representation
  6. Surface based Representation
  7. 3D visualization with anaglyph glass 3D visualization with anaglyph glass
  8. Scale grid
  9. Camera Stations
  10. Factor of magnification of the cameras stations
  11. Camera Station Labels
  12. 3D Error Vectors
  13. Factor of magnification of the 3D Error Vectors
  14. 3D Scale-bars
  15. 3D Axes XYZ

Dock Windows

Dock windows at FOVEX 360S provide an access to your project data as well as edition and visualization of data. The size and location of dock windows can be customized by your own choice. Dock windows of FOVEX 360S are:

Project Explorer

this window is used to visualize and create project data items such as sensor and image data. It also allows editing of property values of certain data items.

Project Explorer


Thumbnail View

this window is used to provide the thumbnail images of the actual images of the project. By double clicking on each thumbnail image the actual image is opened in the Image View.

Thumbnail View


Job Manager

this window shows the current running or queued tasks. It shows the progress of the currently running task.

Job Manager


Message Log

this window provides an area for displaying messages such as progress of activities, warnings or errors. Messages at message log may be filtered out on the basis of severity level and/or keyword.

Message Log


Properties

this window provide information about the selected CAD shape at Image View.

Properties

Tabbed View Windows

The tabbed view windows are divided in four tabs: Image View, Network View, Report View and Layer View. They are located in the main frame of the application as shown here:

Tabbed View Windows


They can be undocked (floated) and be visualized together with other tabs. Undocking is possible by right click on the tab:

They can be undocked (floated) and be visualized together with other tabs. Undocking is possible by right click on the tab


By closing the undocked tab it will be docked to its original location in the main frame.


Image View this tab allows viewing of images and measurement data in a dedicated tabbed window. The window can be undocked (floated) from the main FOVEX 360S window. Each floating window can be placed anywhere on the desktop across multiple screens, if the screen is available.
Data View this tab allows viewing of project data in tabular and text form. The data that is displayed in this view are selected in the Project Explorer. The data presented in this view is not displayed in the Project Explorer itself. This window can be undocked (floated) from the main FOVEX 360S window.
Network View this tab allows viewing of the network and the measurement results in 3D environment. This window can be undocked (floated) from the main FOVEX 360S window.
Layer View this tab allows viewing and setting the layer property. This window can be undocked (floated) from the main FOVEX 360S window.

Status Bar

Status Bar allows display of last line of message logs, pixel coordinate of mouse cursor, the RGB value of the pixel under the mouse cursor, Image zoom level and the unit of the project (dimension, angle):


Status Bar

Application Settings

Application Settings allows the user to configure settings for the application which are related to the software and do not change for different projects.

Application Settings


Application settings. These parameters are applied to all projects.

Property Value
Auto Save Auto save If selected, the project is saved automatically at every value of the following filed.
Save every (minutes) The time interval for saving the project
Units Angle the angle unit of the project
Length The dimension unit of the project
Network View Camera station color The color of camera station in the Network View
Error vector color The color of error vectors in the Network View
Scale bar color The color of scale-bars in the Network View
Background color The background color of the Network View
Selected 3D points The color of the selected points in Network View.